Attention !
L'article que vous regardez est dans l'ancien format du site. Il peut y avoir des problèmes de représentation avec certaines versions du navigateur.

Fermer

Mise à jour 9.15.1 : améliorations techniques

La version 9.15.1 diffère quelque peu des mises à jour de World of Tanks auxquelles les joueurs sont habitués : ici, l'importance du côté technique prend le pas sur le contenu de jeu visible pour les joueurs. Le point le plus important sera le transfert de l'interface de bataille du jeu vers la dernière version du langage de programmation ActionScript 3.0. Dans cet article, nous vous expliquerons la raison de ce changement, ainsi que les avantages d'ActionScript 3.0, et comment éviter les problèmes suite à la sortie de la mise à jour.

 

Pourquoi nous avons besoin de la nouvelle version d'ActionScript 3.0

ActionScript 2.0 a été utilisé pour les solutions de développement de l'interface à l'époque de la sortie du jeu. En 2015, le garage de World of Tanks a été transféré vers ActionScript 3.0, et avec la version 9.15.1, l'interface de bataille du jeu sera elle aussi transférée vers cette nouvelle version. En général, à la suite du transfert vers une nouvelle plateforme, les performances du client restent les mêmes, ou se voient légèrement améliorées. Cependant, le transfert vers ActionScript 3.0 nous offre de nouvelles opportunités d'optimiser le client du jeu. Par ailleurs, le processus de création de modifications sera facilité, les créateurs de mods pourront plus souvent utiliser AutoDesk Scaleform.

 

Modification des performances du client du jeu

Pendant le développement de la nouvelle plateforme pour l'interface de bataille, Wargaming a travaillé en étroite concertation avec les créateurs des mods les plus populaires. Grâce au travail précédemment réalisé, nous avons été en mesure de réduire de façon significative les risques d'impact des modifications tierces sur les performances du client.

Important ! Il n'est pas recommandé d'installer des mods pour une version précédente de World of Tanks, ou de déplacer des mods d'une version précédente vers le répertoire de la 9.15.1, cela pouvant entraîner l'instabilité du jeu.

Malgré la collaboration entre l'équipe de développement de World of Tanks et les créateurs de mods, certains mods peuvent potentiellement ne pas être disponibles avant un certain temps, leur installation risquant de causer des problèmes techniques. Pour cette raison, il n'est pas recommandé d'installer les mods suivants pour le client :

XVM :

  • Tous les composants

Autres :

  • Deluxe info panel
  • Chat with message history
  • Tank icons

Problèmes avec l'utilisation des modifications

De nombreux joueurs utilisent diverses modifications du client. Nous vous rappelons que ces modifications ne sont pas créées par Wargaming mais par des développeurs et utilisateurs tiers. Par conséquent, avec la sortie des mises à jour officielles de World of Tanks, des problèmes peuvent survenir avec votre client de jeu, à cause de ces fichiers modifiés. Vous pouvez rencontrer des problèmes tels que des baisses de performance du jeu, blocages, plantages, textures manquantes, etc. La plupart du temps, ces problèmes peuvent être réglés en supprimant la modification du jeu. Toutefois, une réinstallation complète du jeu peut s'avérer nécessaire.

Important : Wargaming n'est pas responsable des problèmes du client de jeu résultant de fichiers modifiés.

Nous vous rappelons que depuis la sortie de la version 9.12, il est possible d'activer et de désactiver les modifications. Si vous rencontrez des problèmes, essayez de lancer le jeu en mode sans échec.

  • Exécutez le lanceur
  • Cliquez sur la flèche à côté du bouton Jouer
  • Choisissez « lancer le jeu en mode sans échec ».
Fermer